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1. An Overview

Getting In

Having opened SPSS you will get a dialogue box which you can cancel the first time you enter SPSS.
Enlarge the window.

SPSS is like a spreadsheet but it does not update calculations, tables or charts if you change the data.

At the top of the screen are a series of menus which can be used to instruct SPSS to do something.

= Untitled1 |DataSet0 | - SPSS Data Editor

File  Edit “iew Data Transzform  Analyze Graphs Uiities  Add-ons Window  Help

EEHAE It o =EBE A Bd ERE T

SPSS uses 2 windows: The Data Editor, which is what you are looking at and which has 2 tabs at the
bottom, and the Viewer.

The Viewer is not visible yet, but opens automatically as soon as you open a file or run a command that
produces output, such as statistics, tables and charts.

The menus are the same in each window but the icons are different. To switch between the two windows
use the tabs at the bottom of the screen.

The Data Editor window:

vam INLCICTEC LratasetlU] - - L rata Editor
File Edit Wiewny Diata Tran=tarm Analyze Sraphs Litilitie= Add-onzs Wincor

CHA K O =B A B EGE 3%

Open Save Print Review Undo Redo Go to Go to Variables Find Insert Insert  Split Weight Select Show Use Show All
File recent case variable Case Variable Cases Cases labels Sets
dialogue boxes

The Output window:

us FOutputl [Documentl] - SPSS Viewer
Eil= Edit hiEny Datam Transfarm In=sert Format Analyze Zraphs Litilitie= Acdc-c

EH&ME @ B o EiEE o £ fws O

Open Save print Preview Export Recall Undo Redo Goto Go to Variables Select LastShow Use  Show All
File Print recent case variable Case  Output Variable Cases Cases labels Sets
Print dialogue boxes  Go to data

SPSS comes with a large number of sample data files, which this book will use. If you do not have access
to these, use any data set you have access to.
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To open the data file 1991 U.S. General Social Survey.sav
use File > Open > Data

e Double click on the appropriate directories to open each
e Double click on the file 1991 U.S. General Social Survey.sav
At first you will probably be faced by a mass of seemingly meaningless numbers.
If you look along the toolbar you will find the Value labels icon EI Click on this and the output should

look more friendly.

File  Edit “iew Data  Transform  Analyze  Graphs  Uilties  Add) |l'|s Window:  Help

CHA @ o0 =BE A E4 E4E S0

e Click on the Variables icon @? to get an overview of each variable.

& Variables x|

Wariahle Information:

V..I Wariakble 3=k

[v] Respondent's Sex [sex] |~ | [Label Respondent's Sex
[¥] Race of Respondent [ra. Type: F1

[¥] Region of the United Sta. Miszing Walues: none

[w] General Happiness [hap... || |Measurement Level: MNominal
[] = Lifie Exciting or Dul [life]

[¥] Mumber of Brothers and... \alue Labels:

[w] Mumber of Children [chil... 1 Male

[¥] Lge of Respondent [age]
[] Highest ear of School ...
[w] Highest Year School Co...
[w] Highest Year Schoal Ca... [«

2 Female

[coro ][ easte [ cose ][ vew |

Exercise:
e How many Regions of the United States are represented?
Frequencies
e Let's start simply. All that data looks a bit overwhelming so we need to get a handle on it and pick
out the main messages.
e First of all how many men and women are there in this group?
For a simple count, and for percentages use

Analyze > Descriptive Statistics > Frequencies .

SPSS uses Dialogue boxes for the selection of variables and options.
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The source list contains the list of variables, with icons as before indicating data types.

e Your dialogue box may have only listed the variable names, e.g. sex, rather than the variable
labels such as ‘Respondent’s sex’. It is more helpful in analysis to see these labels.

e [fthey are not shownuse Edit > Options

e Select the General tab and at the top under Variable Lists click on the circle Display Labels.

Use the arrow button to move a variable to <2 Frequencies x|
the target list — the Variable(s) box on the M

&3 Respondent's Sex [s... [ *)

rlght \&) Race of Respondert ...
&5 Resion of the United ... [ | Format..

Place Respondent’s sex in the Variable(s) g e Bt o

bOX ,{I Mumber of Children [...
f Age of Respondert [ ||
Highest “ear of Sch

then C“Ck on OK Qisplay freguency tables
‘ Ok H Paste H Reset ” Cancel ” Help ]

The resulting output introduces us to the Viewer window, and shows that 636 respondents, or 42%, were
men. Maximise the Viewer window.

ui *Outputl [Document1] - SPSS Viewer i -10],

File Edt ew Dsta Transform  Insert  Formst  Analyze  Graphs  Ulties  Add-ons WWindows  Helo

cHAR B E 00 BnEk Q® & 95 dléesd +- 00 58
E—@ Cutput DATASET CLOSE Datalietl.

— B Loy GET

*El Frequencies FILE="W:%"ECYSTUDENT" 223P334SP35's own Sample files'adwvert.sav'.

) Title DATASET NAME DataSet3 WINDOW=FRONT.
i MNotes DATASET ACTIVATE DataSetsd.
—L3 Active Dataset DATASET CLOSE Dataget2.
—L& statistics ST
£ Respondents Sex FILE="T:}ECY STUDENTY 223PS34SP35's own Sample files)1991 T.3. General Social Survey.sav”.
DATASET NAME DataSetd4 WINDOW=FRONT.
DATASET CLOSE Datadet3.
SET Unicode=No TFit=BothlLarge OLang=English Small=0.0001 TLook=None.
SET Unicode=No CTemplate=None TFit=BothLarge OLang=English Small=0.0001 TLook=None.
FREQUENCIES WARILBLES=zex
/ORDER=RNALYSIS.

= Frequencies

[DatalSet4] W:4%ECY3SITUDENT), zz3P3S43PS353's own Sawple files' 1991 U.3. General Social Survey.sav

Statistics
Resnondent's Se:
M Valid 1517

Missing 0

Respondent’s Sex
Curnulative
Frequency | Percent | Walid Percent Percent

Walid  Male 636 119 419 1.9

Female ae1 58.1 581 100.0

Total 1517 100.0 100.0

e There is a lot of clutter here.
e Tip: Always delete unnecessary Output, and annotate the rest as you go.
e Click on all the text at the top of the screen and press Delete on your keyboard.
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The left hand pane contains the outline view.
To go directly to an item click on it; very
useful when you have masses of output.

If you don't need it all for the moment you
can hide it by clicking on the minus signs that
appear in the left hand frame.

o Gwee e Asig e (e
AR o DnEir 3% & B'es ¢ &+ + - UE %17

Frequoncies

To hide one item, click on the minus sign.
This is useful if you only want to print a small
selection, as only what is shown is printed.

To change the order in which the items are displayed, drag and drop in the left hand pane. Try it.
To delete an item, click on it and press delete.

e Tip: Never do any analysis without interpreting it.

e To annotate your output use Insert > New Text which provides a text box in which you can write
a comment.

o It appears on the left hand side of the screen with a red arrow at first

e Click on it and the box will open in the right hand pane for you to write in.

\ =8 O“p“t FREQUENCIES VARIABLES=sex
! /ORDER=ANALTSIS.

Frequencies

Statistics .’+

LE Respondent's Sex

[Data3etd] W:YWECY3ITUDENT) z=5F

Statistics
M Walid 1517
Missing ]

Back to the output: itself; this can be edited.
Double click on the table to bring up the Formatting Toolbar.
If it does not appear use View>Toolbar

Download free books at BookBoon.com
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SPSS Pivot Table Respoi _ O] x|

Fil=  Edit “iewy Imzert  Piwvot  Format  Help

Respondent’s Sex
Cumulative
Frequency Fercent Yalid Percent Farcent
Yalid  Male G36 41.9 41.9 41.9
Female 281 581 581 100.0
1517 100.0 100.0
g Ca % Ca e 2

il Ix

& L Showcard Gothic ~ a9~ B I U AF [&

e Click on any text to change its format and use the Formatting Toolbar to do so.
e Double click to rewrite the text itself.
e When you have finished close the Editing window by clicking on the X

o
Qccro”
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The Formatting Toolbar also gives Pivoting Control (!).

Formatting Toolbar

Ord L SansSert ~ 12v B I U 4} EE=

] Ix

Pivoting control is a useful device, which enables you to change the look of your tables.

Click on the icon td to bring up the Pivoting Tray, if it is not already shown.

“§iPivoting Trays xll  Clicking on each of the icons at the edges tells you what they
represent.
:;‘Stat\stu:s
Here the columns are Statistics, and the Rows are Respondent’s
COLUMN Sex.
3 . Drag the Statistics icon on to the Row bar so that the 2 are side
LAYER °§ e by side, to see how the table changes; drag it back before
§ proceeding.

e You can copy Output into Word by clicking on it and using Edit > Copy
e In Word use Edit > Paste.

Exporting your Output to Word

e Output can be exported as a Word RTF file or Text file
e Use File > Export and select the appropriate entry under Type.

Export Output x|

rObjects to Export

Al ) Al visible (%) Selected

rDocument

Topoe: Qptions:
Wyinr iR TF (% doc) | |Layers in Pivat Tables Homar Print Layer setting (set in Takle ...
HTHL (*.htm) li Include Footnotes and Caption Yes

Portable Documernt Format (* pdf)
PovverPoirt (* ppt)

Texd - Plain (* txt)

Text - UTFS (* txt)

Text - UTF16 [*txd)

WiordRTF (*.doc) Change Optionz...

Mone (Graphics only) -]

File Mame:

|C:1D0cumerrts and Settingster<035M%y DocumentsWOUTPUT doc | Browvse...
|—Graphics |

Download free books at BookBoon.com
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Drawing charts

This requires a chapter to itself but the easy way for simple charts is to use
Analyze > Descriptive Statistics > Frequencies

Then click the chart button and select an appropriate chart.

Try it for Region of the United States and draw a bar chart.
The dialogue boxes are shown on the next page.

2 i Frequencies: Charts X

Variahle(s):

&5 Fespondent's Sex [s.. | ™ &) Redion of the United Sta...

& Race of Respondent | 5 Charts... () Nane

;[I General Happiness [.. | | Format... O]
I{I Iz Life Exciting or Dull... O Pie charts
f Mumber of Brathers ..

ol Mumber of Children ... ) Histoorames:

.g& Age of Respondent [... [ wyith normal curve
& Highest Vear of Sch... ||
a& Hinhest Year Schoal

rChart Values

Display frequency tables @ Frequencies O Percentages

[ Ok ” Paste || Reset ” Cancel || Help ‘ I Continue ” Cancel “ Help

In the same way try drawing a histogram for Age of Respondent.

Exercise

Do not spend too long doing this — the aim is to show you it is much easier drawing charts using
Freguencies!

Try drawing the same 2 charts using the Graphs menu and either the Chart Builder or Legacy Dialogs.

After all that ... To return to the data window click on the % icon in the toolbar or click on the tab at
the foot of the screen, or use the Window menu.

The SPSS Tutorial is an extremely useful feature of SPSS

e Click on Help > Tutorial
e Click on the Introduction book and take it from there.

Now take a look at the other very useful help: The Statistics Coach.
Click on Help > Statistics Coach.

As an example, follow the default settings, and click Next each time.

Download free books at BookBoon.com

14



Please click the advert

Stats Practically Short and Simple An Overview

e Summarize, describe or present data Next
e Data in categories Next
e Tables and Numbers Next
e Counts or percentages by category Finish OK

Moving Around

You will be glad to know that the usual short cut keys work here.

Home takes you to the first cell of the row you are in
End takes you to the last cell of the row you are in
Ctrl Home takes you to the first cell of your data
Ctrl End takes you to the last cell of your data.

o
B By 2020, wind could provide one-tenth of our planet’s
ra I n p O W e r electricity needs. Already today, SKF's innovative know-
how is crucial to running a large proportion of the
world's wind turbines.
Up to 25 % of the generating costs relate to mainte-
nance. These can be reduced dramatically thanks to our
stems for on-line condition monitoring and automatic
jeation. We help make it more economical to create
eaper energy out of thin air.
our experience, expertise, and creativity,
industries ca st performance beyond expectations.
Therefore we'need the best employees who can
eet this challenge!

T’% Power of Knowledge Engineering

.

\
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2. Entering Data

Introduction

This is a chapter for anyone faced with the long and tedious task of entering data. Spend a little time
planning this. Wherever possible use numbers rather than text for answers as you can add labels later.

With questionnaires one usually has a separate column for each question, but if you have a question such
as:

“Rate each of the following on a score of 1 to 10 according to importance for the community:
Adequate housing
Good schools
Cultural facilities
Sports facilities.”

You will need a separate column for each category.

Data can be entered directly or imported from an existing SPSS file, spreadsheet or text file, and we shall
cover each of these.

Opening an existing SPSS file.
Use File > Open > Data
Entering Data directly
Entering numbers and text.

The Data Editor Window looks suspiciously like a spreadsheet, and numbers and text can be entered
directly.

Be warned, though it looks like a spreadsheet it does not behave like one. Your charts and output will not
automatically update if you should change the original data, and you cannot enter formulae directly into a
cell, though you can do calculations using a different facility.

e Open anew data sheet. Try Ctrl n; this is the shortcut key to open a new file.
e Oruse File > New > Data

e Try entering some numbers in the first column.
e Type what you want in each cell; press the return key or a cursor key.
e If you make a mistake retype the entry.

Download free books at BookBoon.com
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Entering Data

e Now try to put some text into the same column.
e Canyou? You can type it in but when you press Enter it disappears.
e This is because SPSS has identified the column as a numeric one and won’t allow any text.

e Put some names of countries in the next column to the right including Australia.

e What happens? Most probably it is cut short.
e Try entering numbers in this column — you can but you will not be able to do any calculations

with them as SPSS thinks they are text.
e Your new variables have been given the names VAR00001 and VAR00002 which we will now

change.

Defining Variables

Data View | ‘arisble View u

At the foot of the screen are two tabs. Click on Variable View to get the following screen.

U = », cLU = LTata CAIto = |
File  Edit “iew Dsta Transfortn  Anslyze Graphs  Utilties  Addons  Window  Help
cHE F o nEBE s id SaE B
I Marne | Type ‘ Width | Decimala| Label | “alues Missing Colurmns Align | Measure
1 SAROOO0T Mumeric 8 2 MNone Mone = Right & Seale
2 WARODODZ String 5} 0 Mone Mone 7 = Left &5 Morninal
3

Overtype VARO00001 and VARO00002 with the names of your new variables: numbers and countries
will do.

Click in the cell under Type to get a grey square.

Click on that to bring up a Variable Type box which you can use to define your variable, control the
number of decimal places shown, column width etc.

=t Variable Ty x|

(3) Mumeric

O gome e —
O Dt Decimal Places:
() Scientific notation

() Date

() Dallar

O Custom currency

O String

T Jcme (o ]

Adjusting the width

You can adjust the width of your countries column to 18.

Download free books at BookBoon.com
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Entering Data

Annoyingly when you return to Data View you will still not find Australia displayed, though when you

type it in again it will appear.

Variable names

e They must start with a letter but can now be 64bytes long.

e They can contain numerals e.g. abc12
e But cannot contain spaces or % sign.
o Keep them short.

It is important to keep variable names short so that you can see as much as possible of your data on the
screen. It is quite an art to write short names that still give you an idea of what the column is all about.

Resist the temptation to write Q1, Q2 etc.

You can enter longer descriptive variable labels to explain what the columns are, and these labels will

appear on all output.

Tip: It is better to enter most data as numerical codes and then provide labels explaining what the
codes represent. Adding Variable and Value Labels will be explained after you have loaded the

spreadsheet.

Trust and responsibility

NNE and Pharmaplan have joined forces to create
NNE Pharmaplan, the world’s leading engineering
and consultancy company focused entirely on the
pharma and biotech industries.

Inés Aréizaga Esteva (Spain), 25 years old
Education: Chemical Engineer

- You have to be proactive and open-minded as a
newcomer and make it clear to your colleagues what
you are able to cope. The pharmaceutical field is new
to me. But busy as they are, most of my colleagues
find the time to teach me, and they also trust me.
Even though it was a bit hard at first, | can feel over
time that | am beginning to be taken seriously and
that my contribution is appreciated.

NNE Pharmaplan is the world’s leading engineering and consultancy company o
focused entirely on the pharma and biotech industries. We employ more than nne Dharmaplan
1500 people worldwide and offer global reach and local knowledge along with

our all-encompassing list of services. nnepharmaplan.com
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Entering data via a spreadsheet

Excel spreadsheets can be opened in SPSS with the variable names.

One can also simply copy and paste the data cells from Excel into SPSS but you will have to label the

columns.

e To open a spreadsheet use File > Open > Data
e Ask the dialogue box to display All files and not just the SPSS ones.

2= Open Data

Loak in: |u:}| by Documents

(7= books
[ Camtasia Studio

|_|f In=piration Data
= Interprint Albums

[ My Data Sources
|E Wy eBooks

[,1_? Iy MLISiC

||‘.E._J My Pictures
|5 My videos

|_|f RecordPad

| Safenst Sentinel

/

File name: | ‘

| open

Files of type: [AII Files (*.)

Paste

Find the spreadsheet to open.

SPSS will recognise the format and
automatically give this dialogue box.

Tick Read variable names.

Click OK.

Adding Variable Labels

|:| Minimize string widths bazed on ohzerved values

Cancel

i

& Opening File Options x|

WAECYSTUDEMT Zidneyimasters\PULESES XLES

head variable names|

Range; | |

L Continue —” Cancel ” Help ]

To keep your sheet manageable it is advisable to have short column names.

Variable labels can explain more fully the nature of the variable — you have 256 characters for the

description.

Download free books at BookBoon.com
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e In Variable View of the Data Editor.
e Click on the cell under the Label column and type in a suitable label.

To give an example | might have the variable exgrp, short for exercise group.

The Variable Label for this would then be exercise group.

Adding Value Labels
Value Labels explain numerical codes.

To insert a Value Label

e Click in the cell under the Values column and a small grey square appears.
e Click on this to bring up the Define Variable box.

&= Value Labels x|
-Value Labels

Lakel: |smokes requiarly| |

Add

o J[coree J[_rep ]

Enter a value in the Value box, here itis 1
Type an appropriate label in the Value Label
box, e.g. smokes regularly

Click on Add

Enter the value 2, and a label, e.g. non-
smoker

Add

When all the values have been entered use
Add for the final value, then click on OK

A very useful tip for lots of identical value labels for different variables:

e E.g.ifyouare entering. 0=Noand 1=
Yes,

Enter them for one variable.

Then right click on the cell

Select Copy

Go to a new variable and use Paste
under the Value column.

e This is a huge time saver!

e g yww Qun Dt

=Ha B o LEF A dAd

Bretn  Geens  Uses  adigns  pow e

ElE %%

Narme Width | Decimats Lol [ Vb

o frst pulse rabe  None

Tree
humenc

Missing | Coumers |

| pulset Hune

| pulzez Numanc o secand pulee rate Nong
o (¥, raneath__ Hune 8

o smaking habits |2, smakes | S8R

Nona ]
ran Humenic
| smakas Humanc
| qundor Numeric
| heige
|wight
|acteeny

o 11, malu}

Numane haight in inches  Mana

e

Numene: ] whight in pounds Nor

(] ususl lsval af p. |1, slght]

@ e -
B
AW W

Numane Nana L]

To return to the data click on the Data View tab at the bottom of the screen.

20
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Important note

When selecting data, defining groups, obtaining multiple response sets you will need to use the numeric
value entered in a column and not the text label.

In these circumstances always check what the original data has entered by clicking on the EI icon first.

Finally
It is very easy to make a mistake when entering data.

When it is all entered use Analyze > Descriptive Statistics > Frequencies for each column which will
help you spot the most glaring errors .e. 11 instead of 1

FIRST CONTACT

Get matched to top business
employers via intelligent emails
landing in your inbox.

PLANET CAREER ADVICE Milkround.com: rated-the
Inhabited by insights into #1 graduate recruitment

business careers and orbited M=
by application advice. website in the UK Graduate

MILKROUND SYSTEM - ‘Careers Survey 2009 of

Become a business star with P e . 16,000 university finalists.
internships, placements, R, A5 5

graduate jobs & schemes “

from leading companies. -

) " < ;
www.milkround.com . M I k ; d
_ A - ( HKIFouna.com
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3. Editing and Handling Data

e Open any SPSS file e.g. 1991 U.S. General Social Survey.sav
e Try each of the following.
e |t doesn't matter if you change the data, as long as you don’t save the changes.

Correcting entries

Any entry can be over-typed.
Click on the cell, type in the correct entry and press Enter.
Try changing the value in any cell now.

Deleting entries

e To delete an entry for a cell, click in the cell and press delete.
e Complete columns and rows can be deleted by clicking on the grey cell at the top or side and
pressing the Delete key on the keyboard.

®

e Remember the useful Undo icon! _~~_
Copying cells, columns and rows

e Cells, columns and rows can be copied by first highlighting them then using the Edit Copy menu,
or Ctrl C.
e Move to where you want them copied and use Edit > Paste or Ctrl V.

Inserting a variable (a column)

e Click on the top of the column to the right of where you want the new column to appear, i.e. the
new column will appear on the left

b

e Use the Insert Column icon —
or

¢ Right Click at the top of the column to the right of where you want the new column to appear,
and use Insert Variable
or

e Use Edit > Insert Variable
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Inserting a case (a row)

e Click at the side of the row below where you want the new row to appear.

e Use the Insert Row lcon —

or

¢ Right Click at the side of the row below where you want the new row to appear, and use Insert

Cases.
or

e Edit > Insert Cases

Moving columns

You can drag and drop columns to wherever you like — highlight them first.

Sorting data

SPSS can sort the data, e.g. by Respondent’s Sex Data > Sort Cases.

=2 Sort Cases

Sort by

&3 Face of Respondent ...
&3 Fegion of the United .. | =5
E[I General Happiness [...
ol 1= Life Exciting or Dul...
e& Mumber of Brathers ...

I

E;) Respondert's Sex [Sex]...|

Sort Order

ol Mumber of Chilgren ... ® Ascending

e& Age of Respondent [ _

& Highest vear of sch... |_| () Descending

& Highest ear Schoal .|

[ O ” Paste “ Reset ” Cancel ” Help ]

Saving data and output

In the dialog box highlight Respondent’s
Sex (sex)

Click on the arrow
to transfer it to the Sort by box
OK

Sorting can be Ascending or Descending.

o Data and output have to be saved separately.

e Use File > Save in the appropriate window.

e Charts are saved as part of the Output in a .spv file; data is saved as a .sav file.

e You need to save your Output before it can be exported in another format or printed out.
e Be warned Output from SPSS v15 cannot be opened in VV16.

Exporting Output

e Once you have saved your Output it can also be exported as a Word RTF (Rich Text File) which
contains graphics.
e Use File > Export and choose Word/RTF from the drop down box.
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e Similarly it can exported as a pdf file.
e |tisan excellent rule to save frequently.
Saving Data as an Excel file
e SPSS data can be saved as an Excel File.
e Use Save Data As and from the drop down box select the appropriate Excel format.
e There are a wide variety of other formats to choose from including csv, dat and SAS.

Copying tables and charts into Word

e Inthe Viewer window click on what you want to transfer to Word, either a table or chart.
e Use Edit > Copy and in Word use Edit > Paste, or Ctrl c and Ctrl V.

Printing from SPSS

e Remember that you need to save your Output first.

e You can print directly from the Viewer window using File > Print, but

e use Print Preview first to make sure you have what you want.

e To print just one specific thing click on it first to select it.

e Output that you don’t want can be hidden by clicking on the icons in the left hand pane.
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Recoding into groups

You will find it very useful to be able to recode data.
The 1991 U.S. General Social Survey.sav data includes the number of brothers and sisters each
respondent has in the column headed siblings.

Use Analyze> Descriptive Statistics >Frequencies
to get an idea of what this data looks like.

Humber of Brothers and Sisters

Cumulative
Freguency Fercent Yalid Percent Fercent

Walid 0 T4 4.9 4.9 4.4
1 236 156 157 2006
2 2TH 18.2 18.3 LR
3 236 156 167 ad 6
4 2049 138 1349 G8.5
] 118 T8 T8 6.3
6 a0 a3 a3 al1.r
T a1 5.3 5.4 87.0
8 a8 3.8 3.9 0.9
4 47 31 31 44.0
10 34 22 23 96.3
11 22 1.4 1.4 qr.r
12 11 T T 435
13 q ] ] 2R
14 ] ] ] 494
15 3 2 2 996
16 1 A A 9.7
17 2 A A 99.8
18 1 A A 99.9
iy 1 A A 99.9
26 1 A A 100.0
Tatal 1505 5.2 100.0

Missing DK 4 ]
[ a A
Total 12 8

Total 1617 100.0

It might be useful to regroup the data into subgroups and give each group a numerical code.

As an example | suggest recoding the students into 3 groups:

Those with no brothers or sisters

Those with 1, 2 or 3 brothers or sisters

Those with 4 or more brothers or sisters

Group 1
Group 2
Group 3

25
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Use
Transform & Recode into Different Variables x|
. . MNumeric Yariakle -= Output Yariable: ,
Recode Into Different Variables oy —— P T :"'ﬂm"ﬂ"ﬂh'eT
& Race of Respondert . e
&;aginnf;ms Un:e: i L_;g:n ;
i ol General Happiness [... | s
Place Number of brothers and Sisters ﬂ'sufesxcmnww A (¢l —
. . Number of Chidren [...
(sibs) in the large box. & g2 of Rospondert [ceee |
. i . . & Highest Year of Sch..
Name the new variable sibgrp in the right gwﬂhw*eafsm'
Highest Year School ..
hand box. Gurerrerst | | [smienvas ]
i cosmrma oo [ [aemmnons s e
Click on Change T

Type in the Label sibling groups

Click on Old and New Values to get the next
dialogue box:

On the left hand side under Old Value
Click next to Value and enter 0 in the box.

WERecode into Different Variables: Old and New V2

(Ol Value New Value
(%) vale: @ velue: [1 |
\U \ () System-missing
() system-missing () Copy old valusrs)
O ST G —— On the right hand side, as shown
() Range: -
2dd .
[ Type 1 in the Value box
[ e |
Hirough shange
[ remave |
() Range, LOWEST through value: I k A d d
— Click Add.
() Range, walue through HIGHEST:
[ output variables are strings  L0<h
) &l ther values [ convert numeric strings to numbers ('5->5)
| cortirue || cancet |[ hem

Recode the other groups as follows:
Group 2 1, 2, or 3 brothers or sisters
For Old Value use Range 1 through 3 and for the new Value 2
Don’t forget to click on Add
Group 3 4 or more brothers or sisters
For Old Value use Range, value through highest 4 and for the new Value 3
Add

Having completed the recoding use Continue OK

You should now have a new column on the right of your data sheet headed sibgrp

Revision exercise

e Provide labels for the new variable sibgrp to explain what the numbers represent.
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Doing Calculations on Variables
Calculations can easily be done in SPSS using Transform > Compute Variable

As an example, in the data 1991 U.S. General Social Survey.sav, we shall calculate a new column to
measure age in months.

e Use  Transform > Compute Variable
o fill out the dialogue box as shown then OK

Copenhagen Diversity creating knowledge
Business
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A new variable agemonths has been created.

Target Variable:

Type & Label

&} Respondent's Sex [
&) Race of Respondent ...
% Region of the United ...
d:l General Happiness [
d:l I= Life Exciting ar Dull...
f Mumber of Brothers ...
ol Humber of Children [

................

52 Compute Variable
V

Mumetic Expressiop
= ans* 12

[¢]

(] [l [d(ed (e
Lad [d(ead [ (sd(=d
(o] [ed(ead [ad(2d(ad
M Fedid T

Type in the Numeric Expression ‘long-hand’ or use the keypad.

The list of functions can be useful for your calculations.

Selecting a subset

The age in years has been multiplied (*) by 12

|x

Function group:
A i
Arithmetic

CDF & Moncentral CDF
Corversion

Current DatedTime
Date Arithmetic

4

During your investigations you may want to look only at the data for the males, or females.

e SPSS enables us to select just these cases using
e Data > Select Cases > If condition is satisfied (click in the circle next to this)

e Click on the If ... button under If condition is satisfied

(the If button will not be available if you have not clicked in the circle)
e Enter the appropriate condition, e.g. the example shows what has to be filled in for selecting males.
e Notice you have to put sex =1 not sex = “males”
e This is because the data entered into SPSS in the sex column was numeric

=2 Select Cases: If x|

&; Respondert's Sex [z [*| | Sex=1| =
&) Race of Respondent ... |ﬂ B
% Region of the United ... i i
;[I General Happiness [.. Function group:

ol 1= Lite Exciting or Dull.. |z| IE' il i
& humber of Brothers .. | Arthmetic
ol Mumber af Children [... D El E] E] |E| IEI CLE S NohEertfal €D

&P age of Respondent [... IZ] El E] IT—l Comversion .

4 Highest ear of Sch.. ot DateiTinie ||
f Highest Year Schoal ... El II] III l:l Dats Arithimetic -

& Highest Year School ...
f Highest Year School ...
f R's Occupational Pre...

Functions and Special Yarishles:

;[l Ocoupstional Catego. .
d:l F's Federal Income T...
ol Take active Partin ..
;[I T Dby [okey]

ol To Bl Liked ar ...
ol To Think for Oneself ...
;[l ToWork Hard [work...
il To Heln Others heln

4

l Cortinue i| Cancel || Help
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Continue select Filter out unselected cases OK
(Tip: Do not delete the other cases as they will be lost for good.)

If you scroll down the data sheet you will notice that the females are crossed out on the left, and are now
ignored in any operation. Try a frequency table for Respondent’s sex and see what you get.

To restore all the data use Data >Select Cases > All cases OK

Be warned: this is all too easily overlooked when you have been working on only part of the data, and
then decide to analyse what you think is the complete data set.

Selecting a Random Sample
This is a two stage process:

e First we set the starting point and type of random number generation.
e Then we select the actual sample.

To select the starting point and type of number generator:

e Use Transform > Random Number Generators

i# Random Number Generators |

rActive Generator

[7] Set Active Generator
®) SPSS 12 Compatible

) Mersenne Twister

rActive Generator Initializati
() Random
() Fixed Value

Walue: 2000000

Current Active Generator:  SPSS 12 Compatible

The sctive generstor setting spplies immedistely and to futurs
sessions

| ok || peste || meset || concel |[ hew |

e Select Set Active Generator

e There are two ways in which SPSS version 16 generates random numbers. The current active
random number generator is displayed.

e You should use Mersenne Twister unless you want to reproduce results generated in SPSS
version 12.

e Select Set Starting Point.

e Choosing Random allows a different start point for the random selection each time you enter
SPSS.

e Entering a Fixed Value (which can be any number) allows a random selection to be reproduced.
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e Try them both in the next example and see what happens.

e If you do not set a starting point you will get the same random selection each time you enter SPSS.
e Click OK following your selection.

e Any settings you make will remain in force for future sessions

To select the actual sample:

e Use: Data > Select Cases > Random Sample of Cases
e Click on the Sample button
o Fill out the dialogue box appropriately.

Suppose you wanted to selected a random sample of 4 from the first 9 cases, the box would be set out as
follows:

i Select Cases: Random X|

Sample Size

() Approximately % of all cazes
(%) Exactly D cazes from the first El Ccazes
| Continue _” Cancel || Help |
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Merging Files

e Sometimes you will have two data files relating to the same people, or two files with similar data
but with different people.
e Using Merge Files you can add Variables or Cases to an existing file.

Adding Variables

e Open the first file

e Open the second file which will relate to the same people or objects but with different variables.

e Always open using File Open — do not double click from Windows Explorer as this will often
open another running of SPSS.

e To merge the two files so that you have all the variables in one:
e You must have a key variable which identifies each case, and you must have sorted the files

so that the key variable is in the same order in each.

e Use Data > Merge Files > Add Variables.
e Choose the first file from the list under An open dataset and click Continue

The dialogue box shows an example where the id is the key variable:

£& Add Variables from CensusAtASchoolne x|
Exccludded Variahles: hew Active Detaset:
Gender=(+) T———
Hey_Stage(+) Gender=(")
Region=(<1
ear_Group(+)
+ Hesight+)
Fool_Sizer+)
Mokiler+)
Computer(+)
Internet(s)
Match cases on key variables in sorted files Koy Varisbles
(5) Both files provide cases R
() Mon-active dataset is keyed table
) Active dataset is keyed table
[ indicate case source as variable,
(r)=Active dalaset
(+)=CensusAtASchooinewyar sav[DalaSet2]
o) Ceree ) Lt Lo ) e )
\

Click Match cases on key variables in sorted files and

Both files provide cases

Highlight the id in the left hand box and click on the arrow to paste it into the Key Variable box.
Click on OK and OK again at the warning message and the files will merge.
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Adding cases

e  Open your first file to which you want to add more cases.

e Use Data > Merge Files > Add Cases

e Select An external SPSS data file and click the Browse button, then select your second file.
e Click on Open

e There should be no unpaired variables.

e Click on OK.

e You should now have a file with all your cases.

Design your
own future at
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4. Descriptive Statistics

The Analyze function in SPSS enables us to summarise our data in a number of ways.

The confusion is what to use when, especially as there is often more than one way of doing things in SPSS.

This section provides a guide to what to use, and a brief look at the functions in turn.
Remember this is a book on SPSS not on statistics.

A 'Very Rough Guide' as to what is appropriate to use when:

All the functions are found under Analyze Descriptive Statistics except where stated.

Task SPSS function Comments

Counts Frequencies (offers charts too) Use %'s as well as counts.
%'s are used for comparisons.

Crosstabs

Round %'s to the nearest whole
number in reports.

Averages Frequencies with the Statistics Make sure you use a sensible

and option; measure, e.g. the mean gender is

Measures of spread

Descriptives.

meaningless.

Comparing sets of data

Explore (offers charts too)

Crosstabs

Analyze > Custom Tables

Beware of using boxplots for
inappropriate data, eg nominal.

Crosstab tables can look untidy, so
think carefully about the number of
levels and the information required in
them.

Use for multiple responses.
All tables can be modified.

Looking for relationships

Tables: Crosstabs

Scatterplots
(see Scatter/Dot in the Graphs
menu)

Plots and tables give a visual
impression of possible relationships:
the eyeball test.

You may then need to follow this up
with the appropriate statistical test.
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The Functions

What follows is a brief description of the following functions:
Frequencies, Descriptives, Explore, Crosstabs and a brief look at other Tables.

Frequencies: Analyze > Descriptive Statistics > Frequencies
This is the best function for overall summaries
Frequencies are used when you want to know how many of something you have.

However, additional statistics available via the Statistics button makes it far more useful than just
counting.

The Charts button is particularly useful; automatically producing charts of your data.

The Statistics button brings up the following dialogue box:

&= Frequencies: Statistics x|
rPercentile Values——— Central Tendency
@ [ tean
[] cut poirts for: equal groups [ medisn
|:| Percentile(s): l:l u Mode:
| aa | [ sum

‘ Change |

‘ Remove |

|:| Walues are group midpoints

rDispersion rDistribution
[ stdl. devistion [ Minimum [ skewness
|:| Watiance |:| Maximurm |:| Hurtoziz
|:| Range |:| SE. mean

[ Continue ” Cancel ” Help ]

These statistics would be helpful for age but don’t be tempted to use them for gender!
Example:
Using the 1991 U.S.General Social Survey.sav data

e Use Frequencies to find the summary statistics for age.
e Draw a histogram of the data.

e Start with Analyze > Descriptive Statistics > Frequencies
e Fill out the dialogue box as shown.
e Click on the Statistics button
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i Frequencies x|
Warisblels): l:
&) Respondert's Sex [s... || & Age of Respondent [age]
&, Race of Respondert .| =
&5 Region of the United [ |

{l General Happiness ..

il Is Lite Exciing ar Dull..
f Mumber of Brathers ...
ol Mumber of Children [...
& Highest Year of Sch...
a& Highest Year School

-

Dizplay frequency tables

[ ok esste ][ geset ][ comeat J[ ver |

e We can ask for the Mean, Median, Std deviation, Minimum and Maximum
e Click Continue

e Click on the Chart button

e Select Histograms

e Continue OK

ORACLE
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https://campus.oracle.com
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i Frequencies: Statistics

rPercentile Values

rCentral Tendency
[ quartiles Mean
[ cut paints far: eoual groups Median
D Petcentilels) I:I D Mo
[ 2 | [ 5um
| Change |
| Remave |
[ values are group midpairts
rDispersion rDistribution
Stal. devistion MirimLm [] skewness
D “ariance D Hurtosis
|:| Range |:| SE. mean
[ Continue l [ Cancel ] [ Help ]

s Frequencies: Charts

~Chart Type
O Mone

O Ear charts

x|

O Pie chartz

(©) istograms |

|:| With nortmal curve

rChart Values

{_) Frequencies (&) Percentages

[

Cantinue I[ Cancel ”

Helgp

The Output should look like this.
No-one would pretend that the histogram is well formatted at this stage but that can be corrected.
(See the chapter on charts).
Believe me, it is by far the quickest way to draw a histogram of age.

Statistics

Ane of Respondent

M

Walid

Missing

Mean
Median

Std. Deviation
Minimum
Maximum

1514

4563
41.00
17.808
18

29

Fraguensy

Histogram

1207
100 -

o H

o

40|

20

1 2 @ ) " 10

Age of Respondent

o =48 3
St Dew, =17 608
HelZtd

36

Download free books at BookBoon.com



Stats Practically Short and Simple Descriptive Statistics

Exercise:

Use Frequencies to find the % of respondents living in each of the different regions.
Draw a % bar chart to represent this.

Region of the United States Region of the United States

Cumulative

Freguenc Petcent | Walid Percent Petcent

Valid  MNorth East 679 448 448 448 G
South East 415 7.4 7.4 721
WWest 423 279 279 100.0
Total 1517 100.0 100.0

o S st et
Reglon of the United States

Finding Frequencies for Multiple Response Variables

When you write a questionnaire you often include a question where the respondent can tick more than one
response.

In the data file 1991 U.S.General Social Survey.sav there are several questions relating to health, e.g.

Are you ill enough to go to a doctor?

Have you received counselling for mental problems?
Infertility, are you unable to have a baby?

Do you have a drinking problem?

Using frequencies we could obtain a separate table for each but SPSS can combine these multiple
responses into one table for you.

Use Analyse > Tables > Multiple Response Sets.

e First we need to define our Multiple Response set.
o Fill out the dialogue box as shown, with the various health related questions in the Variables box

e Dichotomies Counted value 1 (because there is a 1 in the column when a respondent has that
problem)

e Set Name: problems
e Click on Add then OK
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8 Define Multiple Response Sets

rsetD
Yariahles in Set:

ol 1 Enoughto Goto & Doc

dj Counzeling for Mental P.

il Infertility, Unable to Hay

ol Crinking Prosiem [hitha)

To Obey [obey] =
To Be WWell Liked or P..
Ta Think for Oneself ..
ToWiork Hard [work

To Help Others [help... 7
legal Drugs (Mariua. . |5
Partner (Hushand, ... [
Child in Hospital [hith?]
Child on Drugs, Drinki...
Desth of a Close Frie...| |

+]

EEELCEEEELE

Wariable Coding

(%) Dichatomies

() Categories

Category Labels Source

(3) variakle labels
() Labels of courted valug
|:| Use variable label a5 set label

S

Sel Label [| |

Sets defined here are nat available in
the Multiple Response Frequencies and
Crosstabs procedure

Mult. Response Sets:

‘ Add Fproblems

[ chane

| Ok || Paste H Reset ][ Cancel

H Help ]

You do not get a table as output but this

Multiple Response Sets

Counted Elermentary
Maime Coded As Yalle Data Type Wariables
Sprohlems Il Enough ta

Dichotomies 1

Zoto a Doctor
Counselling
for Mental
Frohlems
Infertility,
Inable to
Have a Baby
Drinking
Problerm

MuUmeric

Now use Analyze > Tables > Custom Tables
Your variable problems should now appear at the bottom of the Table dialogue box.
Place it in the Rows and Click OK.

3 Custom Tables x|

Table | Thies | Teststaustics | options |

Variables:

| B compact |

‘ Layers

il Eeing Passed Ove.. |~ (

Columns ]

ol Having Trouble wi..
il 0w Business La M
Tl Partrier (Hushand,
il Partrer (Hushand, ..
il one's spouse Bei...
& Most Importart Pro
& Most Importart Pro
&5 Most Importart Pro... | T Enough
&5 Most Impertart Pro.. Counsel nnnn
& sex=1 (FILTER) [ Infertiity, nnnn
Sproblems [~ Drinking .|

Court

nnnn

Rows

$proble...

nnnn

ategories:

[ 1l Enough to Go to & Do
M Counseling for Mental P
M Infertity, Unable to Hav
11 Drinking Problem

1 i —

rDefine rS

[ tice

[ 2 summary stetistics . Posiion. | Columns ~
| %8 categories and Totals ey | Bt e =5

oo ) moem ) [Lcomen ][]

38

Download free books at BookBoon.com



Please click the advert

Stats Practically Short and Simple

Descriptive Statistics

You should get:

Tahle 1
Count

Fproblems [l Enoughto Gotoa 55

Doctar

Counselling for Mental 5a

Froblems

Infertility, Unable to Have

a Baby 35

Drrinking Proklem 17

e For percentages use the No,Summary Statistics button.

e Use Column N%

e Take out the counts by highlighting them and using the back arrow.

e Apply to Selection > OK

i Summary Statistics: x|
Selected Variahle:
Statistics: Cisplay:
Unwweighted Count Statistics | Label | Format Decimals |
Responzes Court |k30unt |nnnn 0 | + ‘
Rowe M % Column h % Calumn b % nAnn 0
Tahle M %
4 i |
Student Student Money - Happy
Discounts Events Saving Advice Days!

F

Wea|thy|u dent.co.uk

Download free books at BookBoon.com

39


http://bookboon.com/count/pdf/26344/39

Stats Practically Short and Simple Descriptive Statistics

This should give you:

Table 1
Column M %
fproblems Il Enoughto Gotoa

Dactar 96%
Counselling far Mental
Problems 10%
Inferility, Unable to Have
a Baby B%
Drinking Problem 0,

Descriptives: Analyze > Descriptive Statistics > Descriptives

2 Descriptives: Optic x|

Analyze > Descriptive Statistics > Descriptives [lgu

Dispersion
St deviation Minimum

Click on Options Dlverance  [¥] Maximm
This brings up the following dialogue box: e LlsEnen

Distribution

[ Kurtosis [] Skewress

Descriptives offers much less than Frequencies - only giving a Dispiay Orver
mean for averages, and the standard deviation and range for (&) Verkae st
Sp l'ead . f::::j;: means
() Descending means
Continue _“ Cancel || Helg

Explore: Analyze > Descriptive Statistics > Explore

This is an extremely useful command when you need to compare two sets of data,
e.g. ages of males and females. It explores the differences.

The example shows the dialogue box set up to compare the ages of men and women in the 1991
U.S.General Social Survey.sav data file.

SPSS has been asked to display both statistics and charts, the latter being boxplots and stem and leaf plots
- again a very useful automatic facility.
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& Explore w x|
Dependent List: i
@ Race of Respondent ...~ & Age of Respondent [age] ‘il
& Region of the United ... | E Plots... |
d:l General Happiness [.. [ | |QPTIT|
d:l |z Life Exciting or Dull... Factor List: =

@@ Mumkber of Brathers .. E) Respondent's Sex [sex] |
il rumber of Children ... ’T|

& Highest Year of Soh... -
& Highest Year School .. " | LabelCazes by
‘f Highest Year School ... ‘ » |

1]

rDisplay
(3) Both () Statistics () Plots

[ OK ” Paste || Reset || Cancel || Help |

Boxplots are a useful way of comparing two or more data sets. They are as the name implies a box whose
length represents the inter-quartile range of the data.

The lower edge of the box is at the lower quartile of the data, and the upper edge at the upper quartile. A
horizontal line indicates the median.

"'Whiskers' are drawn to the minimum and maximum values within 1.5 box-lengths of each end of the box.
Outliers are indicated by o. Values outside 3 box-lengths are indicated by *

Crosstabs: Analyze > Descriptive Statistics > Crosstabs
If you want a table use Crosstabs.
The Tables function is in my opinion only for advanced users of SPSS.
The Crosstabs function produces slightly complex tables, but these can be edited to look tidier.
It has the useful additional facility of doing a Chi-Squared test (and others) if asked - use the Statistics
button. The Cells button enables one to choose Column %'s, Row %'s and Total %'s, but it is advisable to
ask for only one at a time, for clarity.
e Using the 1991 U.S.General Social Survey.sav data file.

e The example shows the dialogue box set up to produce a table of General Happiness by
Respondent’s Sex.
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a2 Crosstabs

&) Race of Respondert [ra... [*)
&) Region of the United Sta. .

,{I I= Life Exciting or Dull [life]| .
g& Mumber of Brothers and...|
ol Mumber of Children [chil... ||
g& Age of Respondent [age]
ﬁ Highest Year of School ...
‘g& Highest Year School Ca...
g& Highest Year School Ca...
ﬁ Highest “ear School Ca...
g& R's Qcoupational Prestig...
d:l Occupationsl Categary [...
d:l R's Federal Income Tax ..

ol Take Active Part inwarl... [+

D Display clustered bar charts

D Suppress tahles

Rom( =)
,{I General Happiness [happy]

Column(=):
&) Respondent's Sex [sex]

-

Layer 1 of 1

| Ol _” Paste || Reszet || Cancel || Help

Read The Spanner online on oxygen.ie
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Which gives:

General Happiness * Respondent's Sex Crosstabulation

Zount
Fespondent's Sex
hale Female Total
General Happiness  Yery Happy 206 261 467
Fretty Happy ar4 4498 arz
Mot Too Happy a3 112 165
Total 633 av1 1504

It would be more helpful to give column %’s here to compare the relative happiness of men and women.

e Todo this click on the Cells button:

And fill out the box as shown: To give
&z Crosstabs: Cell Displa x|
Counts
P r— General Happiness * Respondent's Sex Crosstabulation
[ ] Expected X%owithin Reshondent's Se
Percentages Residuals Respandent's Sex
) hale Female Total
o - unstandertzed General Happiness  very Happy 325% | 300% | 311%
] eolumn] [] standardized ’ ’ ’
) ) Pretty Happy 58.1% a7.2% 58.0%
[ Tctal [ adiusted standardized
Mot Too Happy B.4% 12.9% 11.0%
Noninteger Weights Total 100.0% [ 100.0% | 100.0%
(%) Round cell counts () Round case weights
() Truncate cell courts () Truncate case weights
() Mo adjustments
Continue _” Cancel || Help
e This table needs formatting to give the %’s as whole numbers.
e Double click on the table To bring up the Pivot Table box
"4 SPSS Pivot Tabl =10 x|
File  Edit “iew Insedt Pivot Format  Help
General Happiness * Respondent's Sex Crosstabulation
Statiztics | % within Respondernt's Sex ™
Respondent's Sex
Male Female Total
General Happiness  Very Happy 325% 30.0% 1%
Pretty Happy 589.1% A7.2% 58.0%
Mot Too Happy 3.4% 12.8% 11.0%
Total 100.0% 100.0% 100.0%
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e Highlight the cells in the table

e Click on Format > Cell Properties
e Under the Format Value tab

e Change Decimals to 0.

M Call Properties x|

Fort and Background | Fomsl Yok | Adgrment and Margine

¥ SPSS Pivot Table General Happines: e
File Edit “iew Insert Pivot | Forhs bl
Furmmast
General Happiness * Re gy, ot
7 ] =
Stalistics |% within Respondent's 5| Lo0I= Froperties b e
TableLooks. . S [ |
"
Footnote barker ... :ﬁ:w [
o i
General Happiness  VeryHapp 5S¢t Data Cell Widths... I el
o
Pretty Ha et
ty Hap Autofit — :
Mot Too H o |
Total Renumber Fodtnotes [ (I E
S Rotate Inner Column Lakels
Rotate Outer Row Labels T e e § e

NB Producing a table with a variable taking many different values, e.g. age, is not a good idea.

Tables are tricky!

Look at these 2 tables and answer the following questions:

Male Female Total
General Happiness Very Happy 44% 56% 100%
Pretty Happy 43% 57% 100%
Not Too Happy [32% 68% 100%
Total 42% 58% 100%
Male Female Total
General Happiness Very Happy 33% 30% 31%
Pretty Happy 59% 57% 58%
Not Too Happy 8% 13% 11%
Total 100% 100% 100%

e What % of females were very happy?
e Of those who were very happy, what % were female?

e The answers are 30% of females were very happy and 56% of those who were very happy were
female.

e You may well have got it the wrong way round.

e This is the biggest problem students have — wrongly interpreting %’s in tables.
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The tip is to do both column and row %’s and have them in front of you so that you can see the difference.

e Crosstabs should produce adequate tables for all your needs, but there are other Tables functions
in SPSS.

e My advice is to ignore these unless you feel very confident.

e Plenty of help on Tables is available under the SPSS Help function.

ORACLE

Be BRAVE
enough to reach for the sky

Oracle's business is information - how to manage it, use it, share
it, protect it. Oracle is the name behind most of today’s most
innovative and successful organisations.

Oracle continuously offers international opportunities to top-level
graduates, mainly in our Sales, Consulting and Support teams.

If you want to join a company that will invest in your future,
Oracle is the company for you to drive your career!

https://campus.oracle.com

ORACLE IS THE INFORMATION COMPANY
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5. Charts

Introduction

SPSS provides a wide variety of charts to choose from including bar charts, histograms, pie charts,
scatterplots, and boxplots.

These are accessed via Graphs> Chart Builder

Or by Charts > Legacy Dialogs

Charts should convey a message;
They should help the reader to understand the data, and not confuse.

Try to use as little “ink’ as possible — cluttered charts are not easy to understand.

Drawing appropriate charts is not as easy as it looks, so if you feel daunted use the Charts options under
Frequencies.

For boxplots use Explore.

These two commands will do most of the thinking for you.

In general there are a 2 simple rules which will help:

Decide what your message is and find a chart that conveys it clearly.
Label everything, but don't swamp the chart with words - adjust the font size.

Here are 2 examples

A Bar Chart of Activity Levels

70

a0

a0

40

a0

20

Count

oo moderate

activity level
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Activity level by % of students

Percent

activity level

Spot the differences and decide which is more helpful.

A Simple Bar Chart

moderate

Using the 1991 U.S.General Social Survey.sav data

We shall start by drawing a bar chart of the
regions.

Use Graphs > Chart Builder
Drag the left hand Bar Chart into the main
window

Drag Region of the uNited States into the X
axis box.

Under Titles/Footnotes

Click Title 1 and enter Respondents by
Region

Click Apply

Click on OK

high

Source: Minitab Pulse data

i3 Chart Builder i

Variailes: Chan preview uses example datz
& Respondent's Sex [ |~ | ™

& Race of Respondert |

&, Region of the United

|l Genersl Happiness |
ol s Lite Exciting or Du
& Number of Brathers
ool Humber of Children [
& Age of Respondent
& Highest Year of Sch
& Highest Year School
& Highest ear School

st
South Bast

ot T NorfiEast SouthEast | West

n of the United States

Gallery | Basic Elements | GroupsiPointID | ThesFoutntes |

Choose from:

Favarites
Bor

Line

frea
PiePolar
ScatterDot
Histagram
High-Law
Boxpiot
Dusl Aes

1] klk

o»

OK.

” paste H Reset ” Cancel || Help ‘

Elemert.
Properties...
Ontions:
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Respondents by Reglon

You should get this.

To edit the chart double click on it.

The Chart Editor appears. '
Depending where you double click on the
chart a Properties box should appear with -
different tabs.
o Regicn wf::um::hd States -
e Double click on a bar;
e Under the Fill & Border tab
e Change the colour; : B
° App|y Demh&Ang\e | veriables |
Chart Size | Fill & Border I Categories I Bar Options:
e To change the colour of a single bar e
click once on one bar; P
° it alone will be selected. Sotby: [value | Direction: [ascendng ~|
e Double click on it B -
e apply colour as before. 'E’“m :%:
(%]
e Under Depth and Angle do NOT be
tempted to apply shadow or 3-D.
j(cluded.
e Toremove a category
e Double click on the x axis labels , Cowrr o 5 Soper e
e.g. North East
Click on the Categories Tab (e ] [ coee ] [ oew ]

Highlight North East
Click on the red cross,

Apply.

Percentage Bar Chart

Element Properties = X|

As before use Graphs > Chart Builder =T e 2t

) ar @
e Inthe Element Properties box X-dizl (Barl)
(only the top half is shown) v_axist (Barl)
e Select Percentage () Tile 1
e Apply .
~Statistics

e OK “Wariakle:

Stati=tic:

Percentage () = ]
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e Double click to edit this chart. | ii
e Click once on a bar to select them all

Then on the Show Data Labels Icon x|
. Mumber Format [ Data walue Labels ] Yariahles ‘
e Click on Percent chertSize | Textlayowt | TedStye | Fil & Sorcer
e Transfer to the top box using the arrow \'Lu'ﬁ===
Dizplayed:
o Apply.

KD

Take Count out
e by highlighting Count, and

Mot Displayec

B &

° Using the cross [# Region of the Unted States

Percent
e Apply.
You can amend the format of numbers by ekeliosronyiiiEplaiontions
selecting the Number Format tab. @O SUPRIESS OVEIAREIN [abes

O Manual Cisplay connecting lines to lsbel
AIWayS ShOW %,S as Wh0|e numbers (%) Custom [ hatch label color ta graphic slement
e Type 0 in the Decimal Places box.
e Apply "1
] |

e Use the Text Style tab to increase the
font size: tl’y 12 | Baply H Close ]l Help ]

o Apply.

o
__ You could be one of our future talents

MAERSK INTERNATIONAL TECHNOLOGY & SCIENCE PROGRAMME

Are you about to graduate as an engineer or geoscientist? Or have you already graduated?
If so, there may be an exciting future for you with A.P. Moller - Maersk.

www. maersk.com/mitas
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To change the %’s on the axis to whole numbers

e Click on the y axis once to select it

e Double click to bring up the properties box
e Select the Number Format tab

e Type 0 in the Decimal Places box

e Click Apply

Transpose the chart using the Transpose icon E

The chart can be copied from Output into a Word document using Edit > Copy

When in Word use Edit > Paste.
A clustered bar chart

A clustered bar chart is good for comparisons.

Here we shall compare the general happiness of males and females.

Use Graphs > Chart Builder
Reset

Drag the second bar chart option into the
Gallery.

Drag General Happiness into the X axis box
Drag Respondent’s Sex in to the Cluster on X
box in the top right of the Gallery window.

You should get

Yariables:

=& Chart Builder

Chart preview yses example data

& Respondent's Sex[... |~
& Race of Respondert...
& Region of the Urnited...
Il General Happinsss [
ol s Lite Excctting or Du
4P tumber of Brothers
ol Mumber of Chidren .
& Age of Respondert ..
& Highest Yeer of Sch.
4P Highest vear School
&P Highest Year School

‘Very Happy _Pretty Happy Net Too Happy

[ Male :
|I Famals il General Happiness

Cluster on 5 set color

Gallery | Bsic Elements | GroupsPaitID | TilesFacinotes |

Choose from:

Favorites
Bar
Line

Area

1ol A |5

00|

Wery Mapoy

Pretiy Mappy Hict Tea Happy
General Happlness

Element,
Propetties...

Respondant's Sex

| ™
Wremae
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Percentage Clustered Bar Chart

i@ Element Properties

3| Builder .

GChart preview uses exampls data

Very Happy _Prefty Happy Mot Too Happy

Cluster on X: set calar

Respondents Sex |

General Happiness

Edit Properties of:
Bart
= l ndent's Sex ... |+
M-Mxis (Barl) t Responsent
v-fist (Bart) p N
(GroupCalor (Bart) olthe Lhted. | peer-y
S il Happiness [...[ |
Exciting or Du....
el rof Brothers ..
Statistic: rof Children [...
LPercemage 0 A 'i Respondent ...
Set Parameters Year of Sch...
“ear Schoal.
Year Schoal... f— E
|:| Display error pars > [—
Error Bars bk 5 selscted H il

‘ Basic Hements | Groups/Point 1D |

TilesFactnotes

B xes Choose Flements:

For a percentage chart [ise the
Bar 1 highlighted
Choose Percentage(0) from the Statistic box
Click on Set Parameters
Choose Total for Each X-Axis Category
Continue > Apply > OK

lement Properties Box with

| Transpose | | Element

Warning: if you apply labels to the bars they will give the wrong %’s.

Percentage Clustered Bar Chart using Legacy Dialogs

With correct labels!

For some reason %’s on charts in SPSS pose problems; here is another way of drawing the same chart but

with correct labels. It uses the Legacy Dialogs option.

Use Graphs > Legacy Dialogs >Bar... > Clustered
Use Summaries for groups of cases > Define

-

Use % of cases

Place General Happiness in the Category Axis
Define Clusters by Respondent’s Sex

Click on OK

Edit the chart to

add the Bar Labels as before.,

reducing the decimal places to 0
and increasing the font size.

bl

[ Use chart specifications: from

[ ox ” Paste H Reset H Cancel H Help

<22 Define Clustered Bar: Summaries for Groups of Ca x|
rBars Tfles
& first puise rate [puise1] - B \—I
& second pulse rate [puls Ot cases (2 % of cases Cptiens...
ran iC O cum, %
T nenas hekrt] () Gther statistic (291, mean)
& weight in pounds: [weight]
ol usual level of physical a —— Varlable:
A
| change Statisti |
= Category Axs:
& ‘ \&" smoking habits [smokes]
Define Clusters by:
Panelby
Roys:
[w]
[Iiest
Columns:
[»
[ mest weriabl ol ]
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Think of each colour as being a
length of ribbon.

Respondet s Sax

EMale
Hremals

60.0%

50.0%

All the ribbons are the same

length and represent 100% of
each category (males and e
females).

Percent

30.0%

They are then cut up into the
different sections. 200%-]

10.0%

Wery Happy Pretty Happy Mot Too Happy
General Happiness

www.job.oticon.dk O‘l.'l con

PEOPLE FIRST

Download free books at BookBoon.com

52



Stats Practically Short and Simple Charts

A stacked 2o bar chart

BEWARE: If you ask SPSS to add labels to this it will give you the wrong percentages. Create a table in
cross tabs to find what the %s should be and add the labels as text boxes.

Use Graphs > Legacy Dialog > Bar
Select

Stacked > Summaries for groups of cases
Define

Place General Happiness in the

Category Axis . e
and Respondent’s Sex in Define Stacks Hirena
by

80.0%

Select number of cases N of cases
OK 2

60.0%
40.0%

When your chart appears Edit it

20.0%

0.0%=

From the menu bar select Options
\ery Happy Pretty Happy Hot Too Happy
At the bOttom Se|eCt Scale tO 100% General Happiness

Edit the Y axis label to % by clicking on it.
Add text boxes for labels.

Drawing a panel bar chart
This again uses the Legacy Dialogs.
Panel plots are a style of plot in which subgroups of the data are plotted on separate axes alongside or

above and below each other, with the scale on the axes kept common. These can be very useful plots for
comparing different subgroups.
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To produce a panel bar chart of physical activity by gender use

Graph > Legacy Dialogs >Bar >
Simple,

Put General Happiness in
Category Axis and

500+

400

3004

Respondent’s Sex in the Panel by 200
> Rows box. 100
© 500+

You should get the chart shown.
400

This clearly needs some editing.

3004

Note: The panel option is
available with many of the charts,
and can be generated in a similar 1007

200

xas suspilbbksy

seway

fashion. 0

T
Very Happy

T T
Pretty Happy Mot Too Happy

General Happiness

Drawing a bar chart of more than one variable

Here’s another type of bar chart.

The difference in this bar chart is that
each bar represents a different
variable.

Wvant to Be Well Liked or Popular

You have to be sensible about the

variables you will compare. e
An example is the % of respondents
who

Like to work hard;

Like to think for oneself;

Like to Think for Oneself-

Want to be well liked or popular.

Those who have any of these
characteristics are indicated by a 1 in
the appropriate column.

T T T T
20 40 60 80 100

% of respondents who ...
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To draw the chart use iaBar Charts x|

Graphs >Legacy Dialogs > Bar ... @Simme

SI m p l € m' Clusteredd

’E Stacked

Data in Chart Are

() Summaties for groups of cases

Summaries of separate variables

@ bummaries of separate yariablesl

O Walues of individual cases

Define
{ Define ” Cancel ” Hela ]
At the next dia]ogue box p|ace each of the i@ Define Simple Bar: Summaries of Separate Vatie x|
activities in the Bars Represent box. ————— R (o= )
ry— r [ | |
&5 Region of the United &
. . . ol General Happiness [ IZ‘
They will show MEAN(.... which we will alls L x|
Mumber of Brothers
need to change. R
& Highest Year of Sch.

& Highest Year School o ~Panel by
Highlight them all by holding down Ctrl and 4= ves seros . one
&) . Tupational Pre.

clicking on each. Occupstiona Caiego.
ol F's Federal Incame T Tl re armoe s (o netrae)
ol Take Active Partin . S ‘
ol To Okey [abey] -

Click on Change Statistic. allroeeveresere | | [ 9|

ol To Think for Gressif
ol To work Hard fwvark... =
ol To Help Others [help... || [] Mest variables (ro empty columns:

7

[_] Use chart specifications from:

[ i[ Paste H Reset H Caneel H Help
We shall ask SPSS to calculate the % of il Statistic |
the entries for each variable less than 2 rStatistic for Selected Variable(s)
(Slnce 1 < 2 ) OMEan of values OStandaLd deviation

O Median of values O Wariance

O Mode of values O Minimuth walue

ASk for Percentage belOW ONumber of cages OMa;imum value
Type 2 |n the Value bOX, () 3um of values ) Cumulative sum
i.e. the % of the numbers in the columnN <2 ——  vaweld ]

O Percentage above O Mumber above

@ Percentage helow O Mumber below:

If we had only wanted a count we would O parcertie

have asked for Number below.

Loy | |digh |

O Percentage inside O Mumber inside

Continue
OK

|:| “alues are grouped midpaints

[ Continue ” Cancel H Help

The resulting bar chart doesn’t look quite like the one shown earlier.

By double clicking on it you can open up the Chart Editor window and make the necessary alterations.
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You can change the order of the bars. K
. . Depth & Angle | Varighles |
First write down the order you want. ChortSize | Fil & Eorckr | [ Cotegories ]| Bar options
Warighle:

DOUb|e CI|Ck ona bal’ tO Open Up the DCDIIapge [sum) catedories less than: %

. . rCategories
Properties dialogue box

. Sort by: [Cush:lm '] Direction: [Ascending ']
Select the Categories tab St
Highlight the item you want to move under wiant to B Wl Likedt or Popuisr B
Like to Think for Onesalt

Order Like to VWark Hard E]
Click the up or down arrow. (%]
Apply
OK Excluded:

Liovever margin (2] Uppet margin (%)

[ ey | [ goss || Hen |

Drawing a pie chart

Pie charts are used to examine parts of a whole. As an example of drawing one in SPSS we shall draw a
pie chart of happiness levels.

Always aiming for higher ground.
Just another day at the office for a Tiger.

Join the Accenture High Performance Business Forum

*panIaSAI SYBL [y "3INUIIY 600 ©

On Thursday, April 23rd, Accenture invites top students
to the High Performance Business Forum where you
can learn how leading Danish companies are using
the current economic downturn to gain competitive
advantages. You will meet two of Accenture’s global
senior executives as they present new original research
and illustrate how technology can help forward
thinking companies cope with the downturn.

Visit.student.accentureforum.dk to see the program
and register

, >
Visit student.accentureforum.clk accentu re

« Consulting « Technology  Outsourcing High per formance. Delivered.
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You can use Analyze > Descriptive Statistics > Frequencies... and click on the Charts... button to ask

for a pie chart,

or use Graphs > Chart Builder selecting the Pie Option.

Or use Graphs > Legacy Dialogs >Pie... > Summaries for groups of cases > Define

Use % of cases

Define Slices hy:
General Happiness

Click on OK

Hopefully you have a similar chart to this.

Open the Chart Editing window by double
clicking on the chart.

Add labels
To add % to the labels
Double click on a slice

to bring up the Properties box.

By choosing Percent and General
Happiness

and selecting the position of the labels you

should be able to get the Pie chart shown
on the next page.

See the example dialog box.

vl Define Pie: Summaries for Groups of Cases x|
Slices Represent
S . B
LERE R () Mof cases (3) % of cases Qptions...
&) Race of Respondent
& Renjion of the United () Bum of variable
ol s Life Exciting or Dul \arlable:
& Wumber af Brothers | 5 ‘ ‘ |
ol Mumber of Children [... |+
& Age of Respondert |
& Highest Vear of Sch | - e SlensN
General Happiness [hay
& Highest vVear School ... — |d il Iheppy) |
i rPanel by

f Highest Year School ... Royes:

f R's Ocoupational Pre...
il Occupational Catedo...
il R's Federal Income T...
d Take Active Part in .
d To Obey [ohey]

ol To Be el Liked or P
d To Think for Oneself
d Tior Wbk Hard [weork...
d T Helo Cthers [hel..
d Il Enoughto Gotoa ... ||

[ Mest varishles (rio empty Fosws)
Columns:

[ hest varishlzs (na empty columns)

Template

I:‘ Use chart specifications from:

(o ]

| ok

I[ Paste ” Reset H Cancel H Help I

General Happiness
W Very Happy
EPretty Happy
OINt Too Happy
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Properties x|
Data Yalue Labels I “ariahles |
ChatSize | Tetlayout | TextStyle | Fil 8 Border
rLabels
Dizsplayed

Percent
a General Happiness (happy)

Mot Displayed:

&) XEJP]

-Label Position— -Display Options ———————————

() Automatic [ suppress overlapping labels
O Manusl D Dizplay connecting lines to lakel
@ Custom Match label color to graphic element

[y | [ cose | [ e |

Histogram

Histograms are used for continuous data.

By far the easiest way of drawing a histogram is to use the option under the Chart button in Analyze >

Descriptive Statistics >Frequencies

Alternatively use Graphs >Chart Builder > Histogram
and drag the first option into the Preview Area.

This example shows Age of Respondent dragged on to the X axis.

== Chart Builder

Variables:

Chart preview uses example data

o 5 LITE EeRig &7 O
| Mumber of EBrothers .
ol Humber of Children

Age of

| Hiohest ‘rear of Sch..
& Highest ‘fear Schoal
& Highest Year Schaol
& Highest ear School
& R's Occupationsl Fr
ol coupstionsl Categ
ol R's Federal Income
ol Take active Part in

variabie)

Na categories (sl

‘ i@ Age of Respandent

Gallery | BasicElements | GroupsiFoint | TitesfFoototes |

Choose from

Favorites
e

Line

Area
FiPolar
Scatter Dot
Histogram
High-Low
Bopiot
Dual xes

i el o

Element
Praperties.

ok [ paste |[ meset |[ concel |[ rem
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This is not a well formatted
Histogram.

Double click on the chart to bring
up the Chart Editor.

Double click on a bar for the
Properties box.

Properties (x|
ChartSize | Fil  Border

Binning | Varlables

(2) X axis only
() Z axis only

O and 7 axes
X Axi

O mutomatic
(%) custom
(3) pumber of intervals: |5
) interval wicth
[[] custom value tor anchor: |17.75

Z Axis:

@) tutgmatic
O custom

(®) niumber of imtervals: I:l

O Interval width

[ custam value for anchor: |:|

(] (o) ()

120.0

100.0-

80.0

Frequency
°
i

40,04

2004

Mean =45 63
Stdl. Dev. =17.5808
N=1 514

T T T
40 60 80 100

Age of Respondent

Under the Binning tab

There is an option of selecting
either the number of bins
or the interval width.

Select Custom > Number of Intervals

>5

Apply

Frequency

600

400

200

hlean =45 53
Stdl. Dev. =17.60
N1 514

Age of Respondent

Should you wish to you can superimpose a variety of curves on the histogram using the distribution curve

icon:

—

& i

Which brings up the following Properties box:

Properties

Chart Size

Lines | Yariables

Distribution Curve

rCurves

@

() Poisson

() Cther curves | Deta
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Boxplots

Boxplots are a useful way of comparing two or more data sets.

They are as the name implies a box, whose length represents the inter-quartile range of the data.

The lower edge of the box is at the lower quartile of the data, and the upper edge at the upper quartile.
A horizontal line indicates the median.

'Whiskers' are drawn to the minimum and maximum values within 1.5 box-lengths of each end of the box.
Outliers are indicated by o. Values outside 3 box-lengths are indicated by * (not shown here).

o
Qacha?

it’s an interesting world

Get under the skin of it.

Graduate opportunities
Cheltenham | £24,945 + benefits

One of the UK’s intelligence services, GCHQ’s role is two-fold:

to gather and analyse intelligence which helps shape Britain’s
response to global events, and, to provide technical advice for the
protection of Government communication and information systems.
In doing so, our specialists — in [T, internet, engineering, languages,
information assurance, mathematics and intelligence — get well
beneath the surface of global affairs. If you thought the world was

an interesting place, you really ought to explore our world of work.

- = www.careersinbritishintelligence.co.uk
$ 0 ‘GOVERNMENT
0P 100 R
A p— L

"’ f Applicants must be British citizens. GCHQ values diversity and welcomes applicants from
oo all sections of the community. We want our workforce to reflect the diversity of our work.
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Age of Respondent

Respondent's Sex

These compare ages by gender.

Drawing boxplots can get confusing.

It is easiest to use Explore under Analyze > Descriptive Statistics, but here is how to do it using the

Respandent's Sex

o ko 40 60 & 100
Age of Respendent

Boxplots can also be horizontal.

Graphs menu with two examples to illustrate the differences in different types of boxplots.

First we shall draw the boxplots shown
above.

Use Graphs > Legacy Dialogs>
Boxplot

to obtain the dialogue box.

Select

Simple Summaries for groups of

cases

Define.

Set up the next dialogue box as shown

With Age of Respondent in the (top)
Variable box

And Respondent’s Sex in the
Category Axis box

Click OK and

you should get the boxplots.

Boxplot x

$H¢.$ Simple

HH $$ Clustered

—Data in Chart Are

& Summaries for groups of cases

" Summaries of separate variables

S
s Fooce o espanaert || ™ | | Age o Amspordert [wge] | Lo
i Fegion ol the Unded e
il Gonsrs Hopprasa | * _%
e . :
7 raamioee ot e | [ | poeiCmerty:
il rumcer ot Cracren|
& Pigtest vese ot 5en Pl b
| vighast Vew Schoai e
4 st Vew School [
& vighast vase Senos -
| R Cocvpamanal e
| fl Gecupsson Caisge
oifl s Fecernt ncome T
all T acrvs P Cess
] -
il T Be el Lbed o P |
il 7o T tor Come |
il To ek Hard o [ -
— o || twwm [ men [ owen |[ o |
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The second example is of a clustered box plot which will show the ages, by gender, for each of the
Regions.

Use Graphs > Legacy Dialogs > Boxplot > Clustered
Summaries for groups of cases
Define.

Complete the dialogue box as follows:

Age of Respondent in the (top) Variable box
Respondent’s Sex in the Category Axis box

Region of the United States in the Define Clusters by box.

OK
| Bince ot Respordens | & | & Aon 0l Fospondent fngn| ]
r feeamn| |
17 i rspers | Koo
,‘Irmmtmu:l ot L
4 gt vom st [ LS
Vioiiboeo || O—
_ﬁ:'““”‘“‘:: | | rraneity
fi Detupsbionsl Catega... [~ .
,{ s Frtseral rcomen T >
: T Cety |obery] ;
Il o B Wl Lt 0 P
il To Think for Cnesett oA
[ ermoomern | [ |12
|l MEncughto Coto s
dll Counsetes sor et L
o |- T SR T
The result will should be: Reton g1 e Uit
Wl horth East
80
NB Printing in black and white can
lose the detail in coloured charts. g o
3
This is a good example of that, if you 5 o I
were to print this chart in black and =
white it would be hard to find the ]
median bar in some of the boxplots.
o

T T
Male Female

So, if you know charts will not be
printed in colour, itis a good idea to
change the shadings

Respondent's Sex

There is only one way to master chart drawing in SPSS and that is by having plenty of practice - so over to
you.
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6. Regression and Correlation

Introduction

In statistics when faced with data we attempt to summarise it and then look for patterns. Regression is
about patterns; the possible relationship between two sets of data, bivariate data.

Open the data set advert.sav from SPSS’s own sample data sets.
This has two columns representing spending on advertising and sales in the same period.
The type of questions we might ask about our two variables are:

e Are the two variables related?

e What sort of relationship is there?

e Can we describe (quantify) the strength of the relationship ?
e Can we predict one variable from the other ?

By 2020, wind could provide one-tenth of our planet’s
electricity needs. Already today, SKF's innovative know-
how is crucial to running a large proportion of the
world's wind turbines.
Up to 25 % of the generating costs relate to mainte-
nance. These can be reduced dramatically thanks to our
stems for on-line condition monitoring and automatic
jeation. We help make it more economical to create
eaper energy out of thin air.
our experience, expertise, and creativity,
industries ca st performance beyond expectations.
Therefore we'need the best employees who can
eet this challenge!

T’% Power of Knowledge Engineering

.

\
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Scatter Diagrams

A visual impression is enormously
helpful. ol ota

The first thing to do is to plot the data,
with the independent (x) variable on the
horizontal axis and the dependent (y)
variable vertically. ¢

000

Detranded sales

Sometimes it isn’t obvious which is e

which. Here it is reasonable to suppose T
.. Advaertising spending

sales depend on advertising.

Plot the data with a Scatter Plot
Graphs > Chart builder > Scatter/Dot

Correlation

Correlation quantifies (puts a number to) the strength of the linear relationship between the two variables
and also indicates the direction of the relationship.

The correlation coefficient, r, measures the strength of the linear relationship.
The value of r is between +1 and -1

Values of r close to +1 or -1 represent a strong linear relation.
A value of r close to 0 means that the linear association is very weak.
It could be that there is NO association at all, or the relationship is non-linear.

Pearson's product moment correlation coefficient is used where you have variables which represent
measurements of some form.
Use Analyze > Correlate > Bivariate with the two variables asking for the Pearson coefficient.

Correlations
Advertising Detrended
spending sales
Advedising spending  Pearson Correlation 1.000 918"
Sig. (2-tailed) .0oo
' N 24 24
Detrended sales Pearson Correlation 89167 1.000
Sig. (2-tailed) .000
N 24 24

= Correlation is significant at the 0.01 level (2-tailed).

This shows a correlation coefficient of 0.916 and a significance value of 0.000.

The significance is <0.05 and indicates that if there is no linear relationship between spending on
advertising and sales there is a less than 0.05% chance that a random sample of this size would give a
value of r as extreme as 0.916 .
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Spearman's rank correlation coefficient can also be used. Spearman's coefficient can be used when you
have merely ordered variables, e.g. treatments ranked as to effectiveness. The printout gives a different
value for r having been calculated another way, but the significance value is again <0.05.

Correlations

Advertizing Detrended
spending sales
Spearman's tho  Advedising spending  Correlation Coefficient 1.000 aeg™
Sig. (2-tailed) . oo
N 24 24
Detrended sales Correlation Coefficient Jaeg 1.000
Sig. (2-tailed) oo | .
N 24 24

** Correlation is significant at the 0.01 level (2-tailed).

Correlation and Causation

Correlation quantifies the degree of association between two variables- BUT BEWARE for although two
variables may seem to be related, a change in one may not cause a change in another.

Correlation coefficients are the most frequently misused statistics so when interpreting your correlation
coefficient remember

e that correlation does not mean causation;
e to use your common sense !

Regression

Having discovered that two variables are correlated the next question might be can we model this data
using a straight line?

Can we predict what the sales between and are likely to be from the spending on advertising?

Linear Regression is the technique that is used to find the line that best models the data.

We first have to decide which variable is dependant on the other — here the sales are likely to be dependent
on the spending on advertising.

Use Analyze > Regression > Linear

Place Detrended sales in the Dependent box

and
Advertising spending in the independent box.
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< Linear Regr x|
Dependert: R
Statistics...
&’ Acvertizing spending [a.. - Lf Detrended sales [sales] | st |
Block 10f 1 I AT I
Save...
et |
Options...
Independent(s): | Salons |
gﬁ Advertising spending [advert]
k2
Methad:  |Enter -
Selection Y ariable:
Casze Labels:
WWLS Wyeight:
hdll |
(o] ” Paste || Reset || Cancel || Help |
The output is:
Variables Entered/Removed”
Mode Variahles Wariahles
| Entered Femoved filethod
1 Advertising
spending? Enter
a. All requested variables entered.
b. Dependent Variable: Detrended sales
Model Summary
Mode Adjusted R Std. Error of
| R R Sguare Square the Estimate
1 9162 839 .B32 T3B75
a. Predictors: (Constant), Advertising spending
ANOVAP
Surmn of
| tlodel Soguares df Mean Square F Sig.
1 Regrassion 62.514 1 62514 | 114.548 .0apa
Residual 12.006 22 546
Total 74.520 23
a. Predictors: {(Constant), Advertising spending
h. Dependent Wariable: Detrended sales
Coefficients
Standardized
Unstandardized Coeflicients Coeflicients
Lidodel B Std. Error Beta i Sin.
1 {(Constant) 6.584 402 16.391 noa
Advertising spending 1.071 oo 916 10.703 .0ao

a. Dependent Wariable: Detrended sales

The top box showing the variables entered is self explanatory.

The Model Summary shows the goodness of fit statistics indicating whether the model is a good fit.

e Risthe correlation coefficient measuring the strength of the linear relationship.
o R Square is the coefficient of determination, more usually expressed as a percentage. Here it
tells us that 89% of the variability in the sales can be explained by the variability in the spending

on advertising.
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e The Std Error of the Estimate can be thought of as a typical residual; the difference between
what is predicted by the model and what is observed.

The ANOVA box shows a significance value of .000 This indicates that the regression is significant, i.e.
that there is a useful linear model.

The Coefficients box tells us that the equation that models the line has a slope of 1.071
and an intercept of 6.584,.

We need to know if the variable is actually significant. This is indicated by the significance column on the
right. Sig values > 0 -05 indicate that the coefficient is not significant. Remember that we are trying to
deduce a model to predict price for the population based on a relatively small sample. This means our
values for the coefficients of the slope and intercept are only estimates.

The t value column has done a t-test to test the probability that the coefficient is zero given the sample
data, and the Sig column is the p value for this test.

Here our coefficients are OK so our regression equation would be
sales = 1.071* spending on advertising + 6.584

Trust and responsibility

NNE and Pharmaplan have joined forces to create - You have to be proactive and open-minded as a
NNE Pharmaplan, the world’s leading engineering newcomer and make it clear to your colleagues what
and consultancy company focused entirely on the you are able to cope. The pharmaceutical field is new
pharma and biotech industries. to me. But busy as they are, most of my colleagues
find the time to teach me, and they also trust me.
Inés Aréizaga Esteva (Spain), 25 years old Even though it was a bit hard at first, | can feel over
Education: Chemical Engineer time that | am beginning to be taken seriously and

that my contribution is appreciated.

NNE Pharmaplan is the world’s leading engineering and consultancy company o
focused entirely on the pharma and biotech industries. We employ more than nne Dharmaplan
1500 people worldwide and offer global reach and local knowledge along with

our all-encompassing list of services. nnepharmaplan.com
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We need to know:

1. Isthis line a good fit?
The answer is given by the goodness of fit statistics. and

2. lIsitan appropriate model?
Here we need to look at the residual plots available under the Plots button

e To obtain a chart showing the regression line use Analyze > Regression > Curve Estimation
o filling out the dialogue box as shown.

if& Curve Estimation x|
P o e
Save...
& Detrended sales [sales]
-
(3) Varisble:
| - __& Acvertising spending [a...
) Time
Case Labels: Inciude constant in equation
| nd | Plgt mocels
Models
Linear [ quadratic [ ] Compound [ ] Grawth
[ Logarithmic [ ] Cubic Os [] Exponential
[ inverse [ Powver: [ Logistic
Upper bound: ||
[ Display ANOWA table
o eee [t oo e ]

We have looked at linear Regression but there are other models available from the Regression menu.

Multiple Regression

Multiple regression is used where we have more than one variable which might predict the dependent
variable.

For a linear model we use the same commands as before: Analyze > Regression > Linear
But place more than one variable in the Independents box

This output gives us the values of the coefficients.

Again, we need to know which variables are actually significant.

This is indicated by the significance column on the right.
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Sig values > 0 -05 indicate that the coefficient is not significant.

Remember that we are trying to deduce a model to predict price for the population based on a relatively
small sample. This means our values for the coefficients are only estimates.

The t value column has done a t-test to test the probability that the population coefficient is zero given the
sample data, and the Sig column is the p value for this test.

't

FIRST CONTACT
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7. Statistical Tests

Many students and others want to be able to use the statistical tests in SPSS for hypothesis testing. This
is not a statistics textbook, but a guide to using SPSS, so no theory is included but it is nevertheless
important to stress that you need:

e To be clear about your research question, or the hypothesis you propose to test.
e To be sure that the data you are collecting will actually answer that research question, and
e To collect it from a random sample, to be free from bias.

The procedure is:

e Write your hypothesis and null hypothesis.

e Collect the data.

e Look at the data - what does the evidence of the sample suggest?
e Make a chart if possible.

e Itisusual to test the Null Hypothesis which is a statement of no difference; no association.
e Select an appropriate test.
e Check that the requirements for that test have been satisfied; e.g. was the sample a random sample?

e Carry out the test and identify the p value.
e Isthe p value >=0.05, or < 0.05?

Probability P Significance Decision

Less than 1 in 10,000 <.0001 Significant at .01% level Reject null hypothesis
Less than 1 in 1000 <.001 Significant at .1% level Reject null hypothesis
Less than 1 in 100 <.01 Significant at 1% level Reject null hypothesis
Less than 5in 100 <.05 Significant at 5% level Reject null hypothesis
More than or equal to 5 in 100 >= .05 Not significant Don't reject null hypothesis

Table of P Values and Significance

e Decide if the evidence supports the null hypothesis.
e State the decision about the original hypothesis.

In the examples that follow we shall use the data file 1991 U.S.General Social Survey.sav .
Confidence Intervals: Analyze > Descriptive Statistics > Explore

The requirement for this test is that the sample has been randomly selected.
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Use this to test for a hypothesised value; it will give you the confidence interval for the mean of a

population.

E.g. Test the hypothesis that the mean number of brothers and sisters people have is 3.

Using Analyze > Descriptive Statistics > Explore

e with Age of Respondent in the Dependent List

e with no Factor

e asking for Statistics only

x|
Dependent List: [ iererienall
% Respondent's Sex[s. ]~ — 6& Mumbert of Brothers and... |7§1&1ISIICS... - ‘
& Race of Respondert..| | % | £
a\ Region of the United ... = T
d:l General Happiness [... Factor List |7th ‘
d:l Iz Life Exciting ar Dul... il
ol Mumber of Children... | . |
& Age of Respondent [... o
& Highest Yesar of Sch...| | | Label Cases hy,
& Highest Year Schoaol . |i
Display
() Beth (=) Statistics () Plots
[o],8 J | Paste || Reset | ‘ Cancel || Help
The output is:
Descriptives
Statistic Std. Error
Murmber of Brothers and Mean 3493 RIS
gisters 495% Confidence Interval Lower Bound aTa
for Mean Upper Bound / 4.00
4% Trimmed Mean 369
hedian 3.00
Wariance 9282
Std. Deviation 3.047
Minirmum 0
I xiFrILIET 26
Range 26
Interquartile Range 3
Skewness 1.468 063
kurtosis 3.507 26

The confidence interval would support any hypothesis which suggested that the population mean was
between the Lower Bound of 3.78 and the Upper Bound of 4.09

There is no evidence at the 5% level that the mean number of brothers and sisters is 3.

71
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The One-Sample T test

The requirement for this test is that the sample has been randomly selected.

This is an alternative method to using confidence intervals.
Use this to test for a hypothesised value.
E.g. Test the hypothesis that the mean number of brothers and sisters people have is 3.

Use Analyze > Compare Means > One-Sample T test

usl One-Sample T

Test Variable(s):

x|

&) Respondent's Sex [s...
&) Race of Respondent ...
&) Redion of the United ...

d:l General Happiness [...

ol = Life Exciting or Dul...

ol Mumber of Crildren [...
ﬁ Age of Respondent [...
4 Highest ear of Sch...

& Highest Year Schaal

3D

EY

eg& Mumber of Erothers and...

Options... |

| Test Value:

|

Paste || Reset || Cancel ||

Help

Place Number of Brothers and Sisters in the Test VVariable box
And type 3 in the Test Value box

The output is:

One-Sample Statistics

¥l

Mean

Std. Deviation

Std. Error
Mean

Mumber of Erathers and
Sisters

1605

383

3.047

.07a

One-Sample Test

TestWalue=13

df

Sig. (I-tailed)

ifean
Difference

95% Confidence Interval of the

Difference

Lower

Upper

Mumber of Brothers and
Sister:

11.862

1404

v .oao

832

78

1.09

The significance value is < 0.000 which shows that there is a significant difference between 3 and the
mean number of brothers and sisters of those in the sample.

The Chi-Squared Test for contingency tables

The requirements for this test are that the samples are random and at least 80% of the cells in the table

should have expected counts of at least 5 and no cell should have an expected count less than 1.

The question:
The Research Hypothesis:
The Null Hypothesis:

Is there an association between happiness and gender?
There is an association between happiness and gender.
There is no association between happiness and gender.

7
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Use  Analyze > Descriptive Statistics > Crosstabs

Complete the dialogue box as shown

X

i Crosstabs x|

Fou(s)

d General Happiness [happy]
|d Iz Life Exciting ar Dull [ife]|
& Humber of Brathers and... Column(s): 7

!i-. Mumker of Children [chil... & Respondent's Sex [sex]
& sge of Respondent [age] | |

I& Highest Vear of School
If Highest Year School Co Layer 1 of 1
'& Highest Veat Schoal Co
f Highest Veat School Co
|f R's Occupational Presti...
Id Occupsational Category [...
!i-l R'z Federal Income Tax e

Ed Take Active Part in Warl... |«

[ Previous ] [ et

[] Display clustered bar charts

[] suppress tables

| ok ][ Paste J[ Reset J[ Cancel J[ Help J

oxygen.le

Download 3" level revision guides for free
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e Click on the Statistics button

e Click in Chi-Squared (top left box)

Continue

i#l Crosstabs: Statistic ]

Nominal

|:| Contingency coefficient

|:| Phi and Cramet's W'
|:| Lambcda

|:| Uncertzinty cosfficient

Nominal by Interval

[eta

D Cotrelstions
Ordinal

D Gamma

D Somers' d

D Kendall's tau-b

D Kendal's tau-c

[rappa
[Risk

D MeMemar

|:| Cochran's and Mantel-Haenszel statistics

| Cortinue H

Cancel ‘ | Help

and then on OK

Click on the Cells button
for Counts: Observed Expected
Continue

id Crosstabs: Cell Displ

Counts

B

Expected

Percentages Residuals

|:| Bowr D Unstandardized

|:| Column D Standardized

[] Tatal [ Adjusted standardized
MNoninteger Weights

() Round cell counts
() Truncate cell courts

() N adjustmerts

() Round case weights

() Truncate case weights

Continue | |

Cancel | |

This should bring up the following Output. By looking at the table of expected and observed counts one
can see that there are more men who are happy than expected and more women who are Not Too Happy

(the eyeball test).

General Happiness * Respondent's Sex Crosstabulation

Fespondent's Sex

a. O cells (0%) have expected count less than 4.

So it comes as no great surprise that the value of Chi-squared (7.739)

is significant because the p value is 0.021

hlale Female Total
General Happiness  Wery Happy Zount 206 261 46T
Expected Count 196.5 2704 467.0
Fretty Happy Count aT4 498 ar2
Expected Count 3670 a0a.0 ar2.0
Mot Too Happy  Count g3 112 1645
Expected Count 694 95 6 165.0
Total Count B33 ar 1804
Expected Count F33.0 arv1.0 1804.0
Chi-Square Tests é\
Asvymp. Sid.
Yalue df (2-sided)
Fearson Chi-Square 7.73g4 02
Likelihood Ratio ?_9% 019
Linear-by-Linear
Association 4.812 1 28
M ofvalid Cases 1504

minimum expected countis 69.44.
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The null hypothesis is not accepted.

The conclusion is that this sample shows evidence at the %5 level that there is an association
between happiness and gender, with men appearing to be happier.

t-test for related samples

The requirement for this test is that the sample is randomly selected. There is no need for the underlying
population to be normal provided the sample size is large, i.e. >30.

With related samples we are comparing the differences between pairs of readings that are related: two

pulse readings from the same patient.

Use the SPSS data set New drug.sav for this example. This is a very small data set but we shall assume

the subjects were randomly selected.

The question: Is there a difference in the population means of the first and second pulse
rates of each patient?

The Research Hypothesis:  There is a difference in the population means of the first and second pulse
rates of each patient.

The Null Hypothesis: There is no difference in the population means of the first and second pulse
rates of each patient.

Use Analyze > Compare Means > Paired-Samples T Test

The dialogue box should be
completed by clicking on
Pulse, Timel

clicking on the arrow

and then on Pulse TIme2
and on the arrow

to place them in the variables box.

OK

\sPaired-Samples T Test x|

f first pulse rate [pulset]
f second pulse rate [puls...
@ ran

| smoking habits [smokes]
% Hender

f height in inches [height]
f weeight in pounds [weight]
,{I usual level of physical &

Paired Yariables:
-
Pair Warishle1 Warishle2

1 first puls... second
2

4]
]

[ ok

” Paste H Reset H Cancel ” Help ]
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You should obtain the following Output:

Paired Samples Statistics

Std. Error
Mean il Std. Deviation Mean
Fair1  Pulse, Time 1 2433 12 2605 0752
Pulse, Time 2 2817 12 3326 0960
jk
Paired Sanples Correlations
I+ Correlation Sig.
Pair 1 Fulse, Time 1 & Pulse,
Time 2 12 464 .oaon
Paired Samples Test
Paired Differences
95% Confidence Interval ofthe
Difference
Std. Errar
Mean Std. Deviation Mean Lower Upper 1 of Sig. (2-tailed)
Pair1  Fulse, Time 1- Pulse, -0833 4030 0207 -1488 -017e | -2.803 11 017
. 4

By looking at the sample means one can see they are different. The p value is 0.017
showing that the t value is significant.

The null hypothesis is rejected.

The conclusion is that this sample shows there is a significant difference between the population
means of the first and second pulse rates of patients.

Diversity creating knowledge
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t-test for the differences in the Means of independent samples

The requirement for this test is that the samples are randomly selected. There is no need for the
underlying population to be normal provided the sample sizes are large, i.e. >30.

Here we are comparing the differences between pairs of readings that are not related.
We shall use the data file 1991 U.S.General Social Survey.sav

The question: Is there a difference in the highest year of school completed by males and
females?

The Research Hypothesis:  There is a difference in the highest year of school completed by males and
females.

The Null Hypothesis: There is no difference in the highest year of school completed by males
and females

Use Analyze > Compare Means > Independent-Samples t Test

&2 Independent-Samples T Test i x|
Place Highest Year of School in B 2] [P 2
the Test Variable box and o ek e Lt R
,{lGenera\ Happiness[..
ol Is Life Exciting or Dul.. (]
&Number of Brothers ..
sex in the Grouping Variable gwmermcwenl-
Age of Respondert [.. Grouping Variakle
¢ Hiohest Year Schaol .. | & P T
&’ Highest vear School .| | -
Click on Define Groups. st vest sitod S miscrarted
i Paste | Reset || Cancel || Help |
s Define Groups ' x|
]| T Fill out the box as shown.
Graup 2 The 1 and 2 are the codes for males and females.
() Cut point:
You should get the following Output (which is
Continue _” Cancel || Help | . )
annoyingly wide).
Group Statistics
Respo o Std. Error
nden [+ Mean Std. Deviation Mean
Highest Year of School Male G33 13.23 3143 125
Completed
! Fernale arr 1263 2.8349 jufels
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Independent Samples Test

Levene's Test
for Equality of

Variances t-test for Equality of Means
95%
Confidence
Sig. Interval of the
(2- Mean |Std. Error| Difference
F Sig. t df tailed) | Difference [ Difference| | ower Upper

Highest Year Equal
of School variances 11.226( .001|3.887 1508 .000 .602 55| 298 .906
Completed assumed

Equal
variances 3.824(1276.454| .000 .602 1571 .293] .911
not assumed/ P

Using the eyeball test’again, looking at the means rev,
Levene's test indigates, by the p value, whether
value is < 0.05the evidence suggests that th

s a difference in the sample means.
should assume equal or unequal variances. If the p
ariances are unequal.

Here p=0.001 so we use the Equal variances not assumed line for the t test for the means.

This gives a low p value of < 0.0005 so we conclude that the samples show that there is a significant
difference between the population means of the highest year of school completed by male and females.

Analysis of Variance

We are assuming here that we have independent simple random samples drawn from normal populations.
Analysis of variance is a method for comparing the means of several populations. Simple random samples
are drawn from each and are used to test the null hypothesis that the population means are all equal.

ANOVA compares the variation among groups with the variation within groups.

The question: Is there a difference in the population means of the Highest year of school
completed for each region?

The Research Hypothesis:  There a difference in the population means of the Highest year of school
completed for each region.

The Null Hypothesis: There is no difference in the population means of the Highest year of
school completed for each region.
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e Use Analyze > Compare Means > One-Way ANOVA

Fill out the dialogue box as shown #E One-Way ANOVA _ x|
with Digpendent List [7
&5 Respondent's Sex [ | *] ‘f Highes=t Year of Schoal %'
& Race of Respondert .| = Post Hoc... |
B B d:l General Happiness [ [ | [ |
the Highest Year of School in the et | L i ]
Dependent L|St &7 Number of Brathers ...
! d:l Mumber of Children [...
& Age of Respondent [
. . & Highest ear School .| | |T Eﬁdor:
and Region of the United States as Hishest ear Schonl =1 | €| |@ Region of the Unted Stat
the FaC'[OI’ | Ok | ‘ Pasts || Reset || Cancel || Help |

Click on the Options button and select Descriptive Statistics;
The Output is:

Oneway

Descriptives

_Highestyear of School Completed

95% Confidence Interval far
Mean
[+ E=ETal St Dewiation | Std. Error | Lower Bound Upper Bound | Minimurm | Maxirmum
Morth East GTE 13.00 2TTE 07 1278 13.1 3 20
South East 411 1246 3.352 165 1213 1278 ] 20
Wiest 423 1311 1885 140 12.83 13.38 3 20
Total 1510 12.88 2.984 07T 1273 13.03 0 20
ANOWVA
Highestyear of School Comoleted
Sum of
Sguares df Mean Souare F Sig.
Between Groups 104,635 2 52.317 5914 003
Within Groups 13332.084 1407 5.847
Tatal 13436714 15049

The p value is 0.003 which is <0.05, so we conclude that there is evidence to suggest that that the means
of the 3 populations are not all the same.

Non-Parametric Tests

A parameter is a number describing the population, e.g. the mean or standard deviation, as distinct from
a statistic which is a number that can be calculated from the sample data without needing to know
anything else about the population.

Many statistical tests are parametric tests and make the assumption that the populations involved have
‘'normal distribution'. These tests are very useful and robust but there are occasions when we would like to
compare two samples which we cannot assume come from a ‘'normal’ population, or where the
measurements are on an ordinal scale as distinct from an interval one.

For such populations we use non-parametric tests. We can use these on 'normal’ data too.
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Note: if the values in the population have a skewed distribution, or if the measurement scale is ordinal
then it is better to use the median rather than the mean.

Wilcoxon Rank-Sum Test also known as the Mann Whitney U test for independent samples

The question: Is the population median of the Highest Year of School Completed the
same for males and females?

The Hypothesis: There is a difference in the population median of the Highest Year of
School Completed for males and females?

The Null Hypothesis: There is no difference in the population median of the Highest Year of
School Completed for males and females?

First we need to find the median Highest Year of School Completed for males and females.
Use Explore. males: 13.23; females: 12.63.

These are two independent samples; the variable (Highest Year) we shall treat as continuous.
Use Analyze > Nonparametric Tests > 2 Independent Samples

Complete the dialogue box as shown using the Define groups button for the genders (1, 2).
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ua Two-Independent-Samples Tests x|
Test Variabls List:
i Exact...

&) Race of Responderit & Highest ear of School |Z]

%Re jon of the United .. | 5[ —— | Options... n -
il ccrraramonset. [ [ #] us Two Independent S X|

il Is Life Exciting or Dull...

[»

g& Murmber of Brathers .. Grl:lup 1 s
ol Mumber of Chidren [... | | —— Grouping Variable =

gﬁ Age of Respondent [ | + | Eex it 7]

& Highest Year School L ’7 Grl:lup 2:
& Hichest Yesr School .|~ Celiecroies. |

Testiime- Continue _” Cancel ” Help

Mann-Whitnesy U D Kolmogorowv-Smirnow T

|:| Moges extreme reactions I:‘ Wald-Walfowitz runs

|l Reset H Cancel H Help
The Output is:
Ranks
Besn [+ Mean Rank | Sum of Ranks
gighelsttharofSchool hale 633 306.93 510817.00
pmpiete Female 877 71834 £29958.00 -
Total 1510 This is the p value of 0.000
which is < 0.05.
Test Statistics®
HighestYear - .
of School This indicates that we should
Completed B )
Mann-Whitney U 244885.000 reject the null hypothesis.
Wilcoxan ¥ 6295988.000
Z -3.964
Asymp. Sig. (2-tailed) .0on

a. Grouping Variable: Respondent's Sex

The conclusion is, that on the basis of this sample, there is evidence to suggest that the population median
highest year of schoolc for males and females are not the same.

Compare this with the t-test result. The probabilities are different, but the conclusion is the same.

Wilcoxon Signed-Ranks test for paired samples

We shall again use the SPSS data set New drug.sav for this example. This is a very small data set but we
shall assume the subjects were randomly selected.

The question: Is there a difference in the population median of pulse rates 1 and 2 of
patients.

The Research Hypothesis:  There is a difference in the population median of pulse rates 1 and 2 of
patients.

The Null Hypothesis: There is no difference in the population median of pulse rates 1 and 2 of
patients.
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We are comparing the differences between pairs of readings that are related: the two pulse rates are from
the same patient.

Use  Analyze > Nonparametric Tests > 2 Related Samples

& Two-Related-Samples Tests x|
H Test Pairs:
Complete the dlalOgue bOX &,Drug [chrug] Pair | “ariahled “ariable2 = 77E§ac1... |
&9 Respiratary, Time 1 [res... 1 Pulse, Ti... Pulse, Ti... + ] | Options |
. & Respiratory, Time 2 [res...| [ | 2 Ti
by pIaC|ng bOth &9 Respiratory, Time 3 [res... |L| .; L
B B & Pulze, Time 1 [pulset]
Pulse, Timel and Pulse, Time2 TR -
& Pulse, Time 3 [pulse3]
Test Type
in the Test Pairs box [¥] wicoxan
[T zign
L . [ ] Menemar
and ticking the Wilcoxon box. | Civraevosrans
Ok _“ Paste H Reset || Cancel ” Help
The Output is:
Wilcoxon Signed Ranks Test The Negative Ranks refer to
where Pulse2 is less than

Pulse 1.

The Positive Ranks are those

Ranks
" TSRS E—— where Pulse2 is greater than
Pulse, Time 2- i a
TiLlinSeeiTlme 2- Pulse, Neg.a.lwe Ranks 2 4480 9.00 Pulsel.
Positive Ranks gt 6.33 A7.00
Ties 1€
Total 12 Ties are where Pulse2 equals

a.Pulse, Time 2 < Pulse, Time 1
b. Pulse, Time 2 = Pulse, Time 1 Pulsel
c. Pulse, Time 2 = Pulse, Time 1

Test Statstics” The p value is given as .026
Pulze, Time 2 . . . . .
- Fuls, Tirme which t is <0.05, indicating that
z -2233 we should not accept the null
Asyrnp. Sig. (2-tailed) 026 h th i
a. Based on negative ranks. ypo esis.

b.Wilcoxon Signed Ranks Test

The conclusion is that there is a difference in the two pulse rates of the patients.
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8. And finally

This is not a statistics textbook. This has been a book about using SPSS, written for non statisticians.

You are probably reading it because you have data to analyse, and want to find out how SPSS can help
you. It won’t be able to help unless you understand what your data is measuring, which of your numbers
mean a measurement, and which are merely shorthand codes for answering “Yes” or “I do a lot of
training.”

Time spent thinking about your data is never wasted. Think about what you would like your final report to
say; it will direct your analysis. Firstly though do the simple stuff: look at frequencies, draw charts
(simple ones) and produce two way tables. Make sure you produce two of these each time, one showing
row percentages and one showing column percentages, and don’t be tempted to combine them in one
because that leads to confusion. Keep it simple.

With luck through doing this the data should start to tell you its story, and once you have a handle on that
you will be well away.

Because this is not statistics textbook | suggest you find one that suits you and consult it from time to time.
Better still find a statistician, who will be very grateful for all the simple stuff you have done first!
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